首页 云计算

云安全日报201026:Linux内核发现数据泄露和特权升级漏洞,需要尽快升级

Linux 内核(linux kernel)最近爆出了多个漏洞,这些漏洞会允许攻击者获取特权,未经验证访问机密数据和现有账户。以下是漏洞详情:

漏洞详情

1.CVE-2020-26088 严重程度:高

net / nfc / rawsock.c中的NFC套接字创建中缺少CAP_NET_RAW检查,本地攻击者可以绕过安全机制来使用其创建原始套接字,获取特权,从而未经授权访问机密数据和现有账户。

2.CVE-2020-25645 严重程度:高

当IPsec配置为对GENEVE隧道使用的特定UDP端口的通信进行加密时,两个Geneve端点之间的通信可能不会被加密,从而允许两个端点之间的任何人读取未加密的通信。此漏洞的主要威胁是对数据保密性。

3.CVE-2020-27673 严重程度:高

该漏洞可能导致拒绝服务。每当一个事件被内核接受时,另一个事件就可以通过同一个事件进来通道。这个如果新事件以高速率传入,则可能导致事件处理循环长时间运行。在极端情况下,这可能导致内核完全挂起,导致dom0受到影响时主机出现DoS(拒绝服务)。

4.CVE-2020-27675 严重程度:高

Linux内核事件通道处理代码不会针对被并行删除的同一事件通道来保护事件的处理。

这可能导致访问已释放的内存区域或在事件处理代码中取消对空指针的引用,从而导致系统行为错误甚至崩溃。

5.CVE-2020-25643 严重程度:高

在HDLC_PPP模块中发现了一个漏洞。ppp_cp_parse_cr函数中不正确的输入验证会导致内存损坏和读取溢出,这可能导致系统崩溃或导致拒绝服务。此漏洞带来的最大威胁是对数据机密性和完整性以及系统可用性的威胁。

受影响产品和版本

此漏洞影响Linux Kernel 5.9.1及更早版本(Linux发行版4.6内核以上)Linux 发行版:

RedHat RHEL 8,

Ubuntu Bionic(18.04)及更高版本,

Debian 9和10,

CentOS 8,

Fedora等基于这些内核的Linux发行版都会受到影响

解决方案

升级至Linux kernel 5.9.1或更新版本可修复上述漏洞

文章主要来源:

https://www.auscert.org.au/bulletins/ESB-2020.3669/

官方微博/微信

每日头条、业界资讯、热点资讯、八卦爆料,全天跟踪微博播报。各种爆料、内幕、花边、资讯一网打尽。百万互联网粉丝互动参与,TechWeb官方微博期待您的关注。

↑扫描二维码

想在手机上看科技资讯和科技八卦吗?

想第一时间看独家爆料和深度报道吗?

请关注TechWeb官方微信公众帐号:

1.用手机扫左侧二维码;

2.在添加朋友里,搜索关注TechWeb。

手机游戏更多