首页 云计算

云安全日报201120:IBM DB2发现执行任意代码最高特权漏洞,需要尽快升级

IBM DB2是美国IBM公司开发的一套关系型数据库管理系统,它主要的运行环境为UNIX(包括IBM自家的AIX)、Linux、IBM i(旧称OS/400)、z/OS,以及Windows服务器版本。11月19日,IBM发布安全公告,IBM DB2发现执行任意代码最高特权漏洞,需要尽快升级。以下是漏洞详情:

漏洞详情

来源:https://www.ibm.com/support/pages/node/6370025

1.CVEID: CVE-2020-4701  CVSS评分:8.4 高

适用于Linux,UNIX和Windows的IBM DB2(包括DB2 Connect服务器)容易受到缓冲区溢出的影响,这是由不正确的边界检查引起的,边界检查可能允许本地攻击者使用root用户(可获得系统最高特权)在系统上执行任意代码特权。

受影响产品和版本

所有平台上的IBM Db2 V10.5,V11.1和V11.5版本的所有修订包级别均受到影响。IBM Db2 V10.1和9.7不受影响。

解决方案

运行受影响程序的任何易受攻击的修订包级别的客户都可以从Fix Central下载包含此问题的临时修订的特殊内部版本。根据每个受影响的发行版的最新修订包级别,可以使用这些特殊版本:V10.5 FP11、11.1 FP5和V11.5.4。它们可以应用于适当版本的任何受影响的修订包级别,以修复此漏洞。

来源:https://www.ibm.com/support/pages/node/6370023

2.CVEID: CVE-2020-4739  CVSS评分:7.8 高

Windows上的IBM DB2可能允许本地经过身份验证的攻击者在系统上执行任意代码,这是由Microsoft Windows客户端中的DLL搜索顺序劫持漏洞引起的。通过将特制文件放在受感染的文件夹中,攻击者可以利用此漏洞在系统上执行任意代码。

受影响产品和版本

Windows上的IBM Db2 V9.7,V10.1,V10.5,V11.1和V11.5版本的所有修订包级别均受到影响。Linux和Unix不受影响。

解决方案

运行受影响程序的任何易受攻击的修订包级别的客户都可以从Fix Central下载包含此问题的临时修订的特殊内部版本。根据每个受影响的发行版的最新修订包级别,可以使用这些特殊版本:V9.7 FP11,V10.1 FP6,V10.5 FP11、11.1 FP5和V11.5.4。它们可以应用于适当版本的任何受影响的修订包级别,以修复此漏洞。

查看更多漏洞信息 以及升级请访问官网:

https://www.ibm.com/blogs/psirt/

官方微博/微信

每日头条、业界资讯、热点资讯、八卦爆料,全天跟踪微博播报。各种爆料、内幕、花边、资讯一网打尽。百万互联网粉丝互动参与,TechWeb官方微博期待您的关注。

↑扫描二维码

想在手机上看科技资讯和科技八卦吗?

想第一时间看独家爆料和深度报道吗?

请关注TechWeb官方微信公众帐号:

1.用手机扫左侧二维码;

2.在添加朋友里,搜索关注TechWeb。

手机游戏更多