首页 云计算

云安全日报210315:Ubuntu配套Python发现执行任意代码漏洞,需要尽快升级

Ubuntu是一个以桌面应用为主的Linux操作系统。它是一个开放源代码的自由软件,提供了一个健壮、功能丰富的计算环境,既适合家庭使用又适用于商业环境。Ubuntu为全球数百个公司提供商业支持。

3月12日,Ubuntu发布了安全更新,修复了配套Python发现的执行任意代码,拒绝服务等重要漏洞。以下是漏洞详情:

漏洞详情

来源:https://ubuntu.com/security/notices/USN-4754-3

1.CVE-2020-27619,CVE-2021-3177 CVSS评分:9.8

Python错误地处理了某些输入。攻击者可能会利用此问题执行任意代码或导致拒绝服务。

2.CVE-2019-20907 CVSS评分:7.5

Python错误地处理了某些TAR档案。攻击者可能会利用此问题导致拒绝服务。

3.CVE-2019-17514 CVSS评分:7.5

2016年之前的Python 2和3文档中的library / glob.html可能会误导有关是否发生排序的信息。

4.CVE-2020-8492 CVSS评分:6.5

由于urllib.request.AbstractBasicAuthHandler灾难性的回溯,Python允许HTTP服务器对客户端进行正则表达式拒绝服务(ReDoS)攻击

受影响产品和版本

配套Python 2.7,Python 3.7,Python 3.8的Ubuntu 20.04 LTS与Ubuntu 18.04 LTS都会受到影响.

解决方案

可以通过将系统更新为以下软件包版本来解决此问题:

Ubuntu 20.04:

python2.7-minimal - 2.7.18-1〜20.04.1

python2.7 - 2.7.18-1〜20.04.1

Ubuntu 18.04:

python3.8-minimal - 3.8.0-3〜18.04.1

python3.7 - 3.7.5-2〜18.04.4

python3.8 - 3.8.0-3〜18.04.1

python3.7-minimal - 3.7.5-2〜18.04.4

查看更多漏洞信息 以及升级请访问官网:

https://ubuntu.com/security/cve

官方微博/微信

每日头条、业界资讯、热点资讯、八卦爆料,全天跟踪微博播报。各种爆料、内幕、花边、资讯一网打尽。百万互联网粉丝互动参与,TechWeb官方微博期待您的关注。

↑扫描二维码

想在手机上看科技资讯和科技八卦吗?

想第一时间看独家爆料和深度报道吗?

请关注TechWeb官方微信公众帐号:

1.用手机扫左侧二维码;

2.在添加朋友里,搜索关注TechWeb。

手机游戏更多