首页 云计算

云安全日报210622:Ubuntu Apache服务发现执行任意代码,拒绝服务漏洞,需要尽快升级

Ubuntu是一个以桌面应用为主的Linux操作系统。它是一个开放源代码的自由软件,提供了一个健壮、功能丰富的计算环境,既适合家庭使用又适用于商业环境。Ubuntu为全球数百个公司提供商业支持。

6月21日,Ubuntu发布了安全更新,修复了Apache HTTP服务发现的执行任意代码等重要漏洞。以下是漏洞详情:

漏洞详情

来源:https://ubuntu.com/security/notices/USN-4994-1

1.CVE-2021-26690 严重程度:中

Apache mod_session 模块错误地处理了某些 Cookie 标头。远程攻击者可能会利用此问题导致Apache崩溃,从而导致拒绝服务。

2.CVE-2021-26691 严重程度:中

Apache mod_session 模块错误地处理了某些 SessionHeader 值。远程攻击者可以利用此问题导致Apache崩溃,从而导致拒绝服务,或者可能执行任意代码。

3.CVE-2021-30641 严重程度:中

Apache HTTP Server 版本 2.4.39 到 2.4.46与“MergeSlashes OFF”配置选项在某些情况下会导致意外行为。

4.CVE-2020-35452 严重程度:低

Apache mod_auth_digest 模块错误地处理了某些 Digest nonces。远程攻击者可能会利用此问题导致Apache崩溃,从而导致拒绝服务。

5.CVE-2020-13950 严重程度:低

Apache mod_proxy_http 模块错误地处理了某些请求。远程攻击者可能会利用此问题导致 Apache 崩溃,从而导致拒绝服务。此问题仅影响 Ubuntu 20.04 LTS、Ubuntu 20.10 和 Ubuntu 21.04。

受影响产品和版本

上述漏洞影响Ubuntu 21.04, Ubuntu 20.10, Ubuntu 20.04 LTS, Ubuntu 18.04 LTS

解决方案

可以通过将系统更新为以下软件包版本来解决此问题:

Ubuntu 21.04:

apache2 - 2.4.46-4ubuntu1.1

apache2-bin - 2.4.46-4ubuntu1.1

Ubuntu 20.10:

apache2 - 2.4.46-1ubuntu1.2

apache2-bin - 2.4.46-1ubuntu1.2

Ubuntu 20.04:

apache2 - 2.4.41-4ubuntu3.3

apache2-bin - 2.4.41-4ubuntu3.3

Ubuntu 18.04:

apache2 - 2.4.29-1ubuntu4.16

apache2-bin - 2.4.29-1ubuntu4.16

查看更多漏洞信息以及升级请访问官网:

https://ubuntu.com/security/cve

官方微博/微信

每日头条、业界资讯、热点资讯、八卦爆料,全天跟踪微博播报。各种爆料、内幕、花边、资讯一网打尽。百万互联网粉丝互动参与,TechWeb官方微博期待您的关注。

↑扫描二维码

想在手机上看科技资讯和科技八卦吗?

想第一时间看独家爆料和深度报道吗?

请关注TechWeb官方微信公众帐号:

1.用手机扫左侧二维码;

2.在添加朋友里,搜索关注TechWeb。

手机游戏更多