首页 云计算

云安全日报210708:思科网络安全解决方案发现特权提升漏洞,需要尽快升级

Cisco Web Security Appliance(WSA)是思科(Cisco)公司的一款Web安全设备。该设备提供基于SaaS的访问控制、实时网络报告和追踪、制定安全策略等功能。AsyncOS Software是使用在其中的一套操作系统。

7月7日,思科发布了安全公告,思科网络安全解决方案(WSA AsyncOS)发现特权提升漏洞,建议尽快升级。以下是漏洞详情:

漏洞详情

来源:https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-scr-web-priv-esc-k3HCGJZ

CVE-2021-1359  CVSS评分: 6.3 严重程度:高

用于思科网络安全设备(WSA)的Cisco AsyncOS的配置管理中存在一个漏洞,该漏洞可能允许经过身份验证的远程攻击者执行命令注入并将特权提升到root。

此漏洞是由于对用户提供的 Web 界面 XML 输入的验证不足。攻击者可以通过将包含脚本代码的精心制作的 XML 配置文件上传到易受攻击的设备来利用此漏洞。成功的漏洞利用可能允许攻击者在底层操作系统上执行任意命令并将特权提升到root。攻击者需要具有上传配置文件权限的有效用户帐户才能利用此漏洞。

受影响产品

此漏洞影响 Cisco WSA 的 Cisco AsyncOS 11.8及更早版本,12.0版本,12.5版本(包括虚拟设备和硬件设备)。

解决方案

思科已发布安全更新,对于Cisco WSA 的 Cisco AsyncOS 11.8及更早版本,升级至12.0.3-005版本可修复

对于Cisco WSA 的 Cisco AsyncOS 12.0版本,升级至12.0.3-005版本可修复

对于Cisco WSA 的 Cisco AsyncOS 12.5版本,升级至12.5.2版本可修复

在大多数情况下,可以使用 Cisco WSA Web 界面中的系统升级选项通过网络升级软件。要使用Web界面升级设备,请执行以下操作:

1.选择系统管理 > 系统升级。

2.单击升级选项。

3.选择下载并安装。

4.选择要升级到的版本。

5.在升级准备区域中,选择适当的选项。

6.单击继续以开始升级。进度条显示升级状态。

7.升级完成后,设备重启。

查看更多漏洞信息 以及升级请访问官网:

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-fast-Zqr6DD5

官方微博/微信

每日头条、业界资讯、热点资讯、八卦爆料,全天跟踪微博播报。各种爆料、内幕、花边、资讯一网打尽。百万互联网粉丝互动参与,TechWeb官方微博期待您的关注。

↑扫描二维码

想在手机上看科技资讯和科技八卦吗?

想第一时间看独家爆料和深度报道吗?

请关注TechWeb官方微信公众帐号:

1.用手机扫左侧二维码;

2.在添加朋友里,搜索关注TechWeb。

手机游戏更多