首页 云计算

云安全日报210923:思科IOS XE操作系统发现远程代码执行漏洞,需要尽快升级

Cisco IOS和IOS XE是思科(Cisco)公司旗下路由器和交换机等网络设备广泛采用的互联网操作系统。9月22日,思科发布了安全更新,修复了Cisco IOS XE操作系统中发现的远程代码执行漏洞。以下是漏洞详情:

漏洞详情

来源:https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ewlc-capwap-rce-LYgj8Kf

CVE-2021-34770 CVSS评分:10.0 高危

用于 Cisco Catalyst 9000 系列无线控制器的 Cisco IOS XE 软件的无线接入点控制和配置 (CAPWAP) 协议处理中存在一个漏洞,该漏洞可能允许未经身份验证的远程攻击者以管理权限执行任意代码或导致拒绝服务 (DoS) ) 受影响设备的状况。

该漏洞是由于在验证 CAPWAP 数据包过程中发生的逻辑错误造成的。攻击者可以通过向受影响的设备发送精心制作的 CAPWAP 数据包来利用此漏洞。成功的利用可能允许攻击者以管理权限执行任意代码或导致受影响的设备崩溃并重新加载,从而导致拒绝服务条件。

受影响产品

如果以下 Cisco 产品运行用于 Cisco Catalyst 9000 系列无线控制器的 Cisco IOS XE 软件的易受攻击版本,则此漏洞会影响这些产品:

1.适用于 Catalyst 9300、9400 和 9500 系列交换机的 Catalyst 9800 嵌入式无线控制器

2.Catalyst 9800 系列无线控制器

3.适用于Cloud的 Catalyst 9800-CL 无线控制器

4.Catalyst 接入点上的嵌入式无线控制器

解决方案

思科已经发布了解决上述漏洞的软件更新(具体解决修复方案,可以参看思科官网),以下是修复方案重要说明:

1.对购买了许可证的软件版本和功能集提供支持,通过安装,下载,访问或以其他方式使用此类软件升级。

2.从思科或通过思科授权的经销商或合作伙伴购买的,具有有效许可证的软件可获得维护升级。

3.直接从思科购买但不持有思科服务合同的客户以及通过第三方供应商进行购买但未通过销售点获得修复软件的客户应通过联系思科技术支持中心获得升级。

4.客户应拥有可用的产品序列号,并准备提供上述安全通报的URL,以作为有权免费升级的证据。

查看更多漏洞信息 以及升级请访问官网:

https://tools.cisco.com/security/center/publicationListing.x

官方微博/微信

每日头条、业界资讯、热点资讯、八卦爆料,全天跟踪微博播报。各种爆料、内幕、花边、资讯一网打尽。百万互联网粉丝互动参与,TechWeb官方微博期待您的关注。

↑扫描二维码

想在手机上看科技资讯和科技八卦吗?

想第一时间看独家爆料和深度报道吗?

请关注TechWeb官方微信公众帐号:

1.用手机扫左侧二维码;

2.在添加朋友里,搜索关注TechWeb。

手机游戏更多